Trang 1/2 12 CuốiCuối
Hiện kết quả từ 1 tới 10 của 13
Like Tree1Likes

Chủ đề: Quảng cáo không hiển thị


  1. #1
    Thành Viên Mới Avatar của htt_246
    Tham gia
    Jan 2017
    Bài gửi
    10

  2. #2
    Super Moderator Avatar của sieuload
    Tham gia
    Aug 2010
    Bài gửi
    11.810
    Quote Nguyên văn bởi htt_246 Xem bài viết
    Mấy a cho e hỏi, sao e build app giờ nó ko hiện được ads, cùng source + id mà file apk e build lúc trc thì vẫn hiện, còn giờ build nó không hiện được, dù vẫn có request lên.
    Admob thì reset ID quảng cáo của máy. Khởi động lại test nhé.




  3. #3
    Thành Viên Mới Avatar của htt_246
    Tham gia
    Jan 2017
    Bài gửi
    10
    Quote Nguyên văn bởi sieuload Xem bài viết
    Admob thì reset ID quảng cáo của máy. Khởi động lại test nhé.
    E thử hết rồi a, vẫn không dc, e thay id test thì ok, file cũ id đó vẫn lên, build lại không lên, mặc dù đã thử chạy cái sample của nó. Sample chỉ thay id test mới lên, còn id khác thì chịu luôn ạ, e thấy nhiều người cũng bị mà chưa bik do j



  4. #4
    Super Moderator Avatar của sieuload
    Tham gia
    Aug 2010
    Bài gửi
    11.810
    Quote Nguyên văn bởi htt_246 Xem bài viết
    E thử hết rồi a, vẫn không dc, e thay id test thì ok, file cũ id đó vẫn lên, build lại không lên, mặc dù đã thử chạy cái sample của nó. Sample chỉ thay id test mới lên, còn id khác thì chịu luôn ạ, e thấy nhiều người cũng bị mà chưa bik do j
    Cái này mình bị mà. Do Admob nó kg hiện quảng cáo 1 số máy có ID trùng với ID tài khoản. Điện thoại Samsung hay bị nhất. Cứ thấy số liệu tỉ lệ fill rate chủa full ads là trên 99% là ok. Banner Admob thì fill rate khá tệ, gần đây của mình chỉ khoản 50%.

    Bác mua 1 cái phone Android gốc của Google để test cho an tâm nhé.

    Proguard nếu có bật thì nhớ thêm dòng sau:
    -keep class com.google.** { *; }


    Lần sửa cuối bởi sieuload; 04-12-18 lúc 01:44 AM


  5. #5
    Thành Viên Mới Avatar của VietApps
    Tham gia
    Jun 2015
    Bài gửi
    12
    Quote Nguyên văn bởi sieuload Xem bài viết
    Cái này mình bị mà. Do Admob nó kg hiện quảng cáo 1 số máy có ID trùng với ID tài khoản. Điện thoại Samsung hay bị nhất. Cứ thấy số liệu tỉ lệ fill rate chủa full ads là trên 99% là ok. Banner Admob thì fill rate khá tệ, gần đây của mình chỉ khoản 50%.

    Bác mua 1 cái phone Android gốc của Google để test cho an tâm nhé.

    Proguard nếu có bật thì nhớ thêm dòng sau:
    -keep class com.google.** { *; }

    Tình hình là mình cũng bị giống bạn @htt_246
    Build lại thì không hiện ads của admob. Thử tạo app mới + package name mới + ad id mới cũng không hiện (dùng addTestDevice thì hiện bình thường).
    errorCode trả về là 3 (ERROR_CODE_NO_FILL)
    Tài khoản của mình vẫn hoạt động bình thường (đã hoạt độ khoảng 2 năm), app cũ vẫn hiện ads bình thường.
    Mình thấy cũng rất nhiều người bị tình trạng đó, trên stackoverflow cũng thấy kêu nhiều.
    Giờ không biết phải làm sao. Hiện tại mình đang dùng version android studio, gradle, firebase ads đều mới nhất.
    Không biết có phải do phiên bản mới này bị không.
    Mình cũng đã thử test trên nhiều máy. Gửi cả cho bạn bè để chạy thử cũng không thấy hiện (khoảng trên 30 máy).
    Kiểm tra trong admob thì thấy lượng request nhiều nhưng hiển thị = 0.

    Bác @sieuload nghiên cứu giúp với ạ.

    classpath 'com.android.tools.build:gradle:3.2.1'
    classpath 'com.google.gms:google-services:4.2.0'
    implementation 'com.google.firebase:firebase-core:16.0.6'
    implementation 'com.google.firebase:firebase-ads:17.1.2'




  6. #6
    Super Moderator Avatar của sieuload
    Tham gia
    Aug 2010
    Bài gửi
    11.810
    Quote Nguyên văn bởi VietApps Xem bài viết
    Tình hình là mình cũng bị giống bạn @htt_246
    Build lại thì không hiện ads của admob. Thử tạo app mới + package name mới + ad id mới cũng không hiện (dùng addTestDevice thì hiện bình thường).
    errorCode trả về là 3 (ERROR_CODE_NO_FILL)
    Tài khoản của mình vẫn hoạt động bình thường (đã hoạt độ khoảng 2 năm), app cũ vẫn hiện ads bình thường.
    Mình thấy cũng rất nhiều người bị tình trạng đó, trên stackoverflow cũng thấy kêu nhiều.
    Giờ không biết phải làm sao. Hiện tại mình đang dùng version android studio, gradle, firebase ads đều mới nhất.
    Không biết có phải do phiên bản mới này bị không.
    Mình cũng đã thử test trên nhiều máy. Gửi cả cho bạn bè để chạy thử cũng không thấy hiện (khoảng trên 30 máy).
    Kiểm tra trong admob thì thấy lượng request nhiều nhưng hiển thị = 0.

    Bác @sieuload nghiên cứu giúp với ạ.
    Mình test cũng bị như bạn nhé. 100% máy test của mình điều bị luôn.

    Mình chỉ thấy khi trên máy ảo thì có hiện thôi. Tỉ lệ Full Banner của mình giờ là 99%, Banner thì còn 40%.

    Không rỏ có phải do FireBase không nữa nhưng từ khi sài cái này thấy quảng cáo doanh thu không được như xưa. Facebook thì khó khăn nên cũng chã biết làm sao?




  7. #7
    Thành Viên Mới Avatar của VietApps
    Tham gia
    Jun 2015
    Bài gửi
    12
    Quote Nguyên văn bởi sieuload Xem bài viết
    Mình test cũng bị như bạn nhé. 100% máy test của mình điều bị luôn.

    Mình chỉ thấy khi trên máy ảo thì có hiện thôi. Tỉ lệ Full Banner của mình giờ là 99%, Banner thì còn 40%.

    Không rỏ có phải do FireBase không nữa nhưng từ khi sài cái này thấy quảng cáo doanh thu không được như xưa. Facebook thì khó khăn nên cũng chã biết làm sao?
    Của mình còn = 0 hết ấy.
    Mình đã thử cả trên thiết bị mới mua chưa cài app lần nào cũng không thấy hiện.
    Ip thì đổi liên tục rồi.
    App muốn update, app mới,... đều không hiện.
    Giờ ads không hiện thì không biết làm thế nào.

    Mình bị cũng phải tầm 1 tháng rồi, tìm hiểu nhiều cách mà không được, thấy bế tắc quá :-(



  8. #8
    Super Moderator Avatar của sieuload
    Tham gia
    Aug 2010
    Bài gửi
    11.810
    Quote Nguyên văn bởi VietApps Xem bài viết
    Của mình còn = 0 hết ấy.
    Mình đã thử cả trên thiết bị mới mua chưa cài app lần nào cũng không thấy hiện.
    Ip thì đổi liên tục rồi.
    App muốn update, app mới,... đều không hiện.
    Giờ ads không hiện thì không biết làm thế nào.

    Mình bị cũng phải tầm 1 tháng rồi, tìm hiểu nhiều cách mà không được, thấy bế tắc quá :-(
    Bạn phải liên hệ Admob Support để xem coi app của bạn có bị ban không nhé.




  9. #9
    Thành Viên Mới Avatar của VietApps
    Tham gia
    Jun 2015
    Bài gửi
    12
    Quote Nguyên văn bởi sieuload Xem bài viết
    Bạn phải liên hệ Admob Support để xem coi app của bạn có bị ban không nhé.
    Nãy mình định gửi mail nhờ support mà vào Group thấy nhiều người bị như mình quá nên thôi.
    Dường như đây là lỗi chung thì phải. Có thể xảy ra ở phiên bản sdk nào đó. Chứ account của mình vẫn hoạt động bình thường, kiểm tra mail cũng không thấy gì ấy.
    https://productforums.google.com/for...mob-help-forum


    Quote Nguyên văn bởi htt_246 Xem bài viết
    E thử hết rồi a, vẫn không dc, e thay id test thì ok, file cũ id đó vẫn lên, build lại không lên, mặc dù đã thử chạy cái sample của nó. Sample chỉ thay id test mới lên, còn id khác thì chịu luôn ạ, e thấy nhiều người cũng bị mà chưa bik do j
    Quảng cáo của bạn đã hiện chưa và bạn đã giải quyết được vấn đề chưa vậy ?



  10. #10
    Thành Viên Mới Avatar của VietApps
    Tham gia
    Jun 2015
    Bài gửi
    12
    Quote Nguyên văn bởi sieuload Xem bài viết
    Bạn phải liên hệ Admob Support để xem coi app của bạn có bị ban không nhé.
    Mà app dùng ads của admob có bắt buộc phải upload lên store (appstore/play store) thì mới hiện ads không bạn nhỉ ?
    Ngày trước thì không nhất thiết, còn bây giờ thì không biết nó có bắt buộc không.



Trang 1/2 12 CuốiCuối

Đánh dấu

Quyền viết bài

  • Bạn không thể gửi chủ đề mới
  • Bạn không thể gửi trả lời
  • Bạn không thể gửi file đính kèm
  • Bạn không thể sửa bài viết của mình
  •